Home > CentOS, VPS > CentOS 5 lighttpd-1.5.0.cache No package ‘lua’ found

CentOS 5 lighttpd-1.5.0.cache No package ‘lua’ found

checking for LUA… configure: error: Package requirements (lua >= 5.1) were not met:
If you are here, anyway you tried to compile lighttpd –with-lua
and if you got this one:
No package ‘lua’ found,
the soliution is bellow:

root@lb1:[Mon Oct 12 21:04:48]:[/opt/installs/lighttpd-1.5.0.cache]$ wget  http://www.lua.org/ftp/lua-5.1.4.tar.gz
tar xvfz lua-5.1.4.tar.gz
cd lua-5.1.4
make linux
make install
cp etc/lua.pc /usr/lib/pkgconfig/
and you are ready to try again

Advertisements
Categories: CentOS, VPS Tags: , ,
  1. October 16, 2009 at 12:05 pm

    Or you can install lua and lua-devel via yum:
    yum -y install lua lua-devel
    This packages are provided by third party repositories such as epel and rpmforge.

  2. dragkh
    February 3, 2010 at 7:40 am

    same issue with installing lua on debian – so I did aptitude remove all installed lua packages, got the latest lua source and compiled, then its critical to cp etc/lua.pc /usr/lib/pkgconfig/ in a view to configure the lighttpd –with-lua … 🙂

  1. February 26, 2010 at 8:25 pm

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: